WordPress5.3がリリース アップデート非推奨です


Warning: DOMDocument::loadHTML(): Unexpected end tag : li in Entity, line: 4 in /home/c8142937/public_html/careru.jp/alpage/wp-content/themes/cocoon-child-master/functions.php on line 230

Warning: DOMDocument::loadHTML(): Unexpected end tag : ol in Entity, line: 4 in /home/c8142937/public_html/careru.jp/alpage/wp-content/themes/cocoon-child-master/functions.php on line 230

2019年11月12日にWordPress最新バージョンとして5.3がリリースされました。

内容はブロックエディタ(Gutenberg)と、WordPress標準テーマのTwenty Twentyに関するものがメインのようで、セキュリティアップデートはありませんでした。

よって必ず更新しなければならないアップデートというわけではありません。

ですが、結構な数のバグが修正されたとのことなので、定期的にアップデートを行っている方はアップデートしておきましょう。

管理画面のUIデザインが変わった

触っていて気づいたのですが、管理画面の各種UIがモダンなデザインに変わっていました。

こんな感じに、ボタン関係のデザインが軒並み変更されています

特に使い勝手かは変わったわけではありませんが、WordPress開発者も色々試している最中なのでしょう。

意味あるのかな?と感じたりもしますが(笑)

当サイトでは不具合発生

一部分ではありますが、管理画面で使用していた自作プラグインのjQuery処理がエラーになるという不具合がありました。

関数名を$からjQueryに変えるだけで解決しましたが、管理画面の表示がおかしいという場合はjQuery関係のエラーが発生してるかもしれません。

追記

Twitterなどで情報を集めていたところ、ほかのサイトでも不具合に悩まされている方が多くいられました。

特にAFFINGERのエディタ機能が一部使えなくなる不具合が起きているようです。

WordPress5.3、ブロックエディターに大きな変更があり、affingerでもエディタが使えない報告があるので、自分が使っているテーマ側の公式アナウンスを待った方が良いかもしれませんね

2
0
2019-11-13 10:18:38

AFFINGER使ってる人は要注意!
WordPress5.3にアップデートすると、ClassicEditorで一部不具合ありました。
対応できてからアップデートしましょう。

0
0
2019-11-13 20:13:11

AFFINGERは持っていないので憶測に過ぎませんが、当サイトと同じ原因で動作不良を起こしているのかもしれません。

現在はバグ修正済みのアップデートが公開されているようなので、AFFINGERユーザーは忘れずアップデートを適用するようにしましょう。

PHPの必須バージョンは変更なし

現在WordPressが要求しているのはPHP5.6以上ですが、今回のWordPressアップデートで最低バージョンが引き上げられることはありませんでした。

コメント

タイトルとURLをコピーしました